Metamask Change my Wallet Adress When I RESET it

When i Reset my wallet, the account number change! how rude is that.

how can i retrieve my old wallet.

I need my money back. thats your fault.

I know my phrase and everything, i have proofs…you just need to return my money and my account wallet

this is my wallet address you deleted.


when i reset my account you change it

how can i get my money back if you gave me another wallet address.

this is the new address you given


just return the money please.


To reset your account’s transactions you do it in Advanced Settings. You probably deleted the extension and re-installed.
To get your wallet back you must use your seed words to import your wallet instead of creating a new wallet.

1 Like

Any advice about changing wallet addresses? @uniquenospacesshort

1 Like

No way to change a wallet’s address, you will have to create a new one and transfer your funds there. You also can’t change a wallet’s secret phrase

hello, i have the same thing happen that the wallet address has been changed, its quite frustrating that he new numbers have been assigned to my account and now i cannot go to the original account. I dont see this exact issue being addressed in the FAQ or message boards.

1 Like

sorry to inform you. but i cant do anything to my account.
im so disappointed. metamask dont resolve my problem.


mesmo problema aqui, aguardando a metamask resolver


the same thing happens to my account and I cannot retrieve my original account.


After contacting support, and opening a ticket
Support now has marked my ticket as ‘solved’
Certainly it is not solved
I submitted the same issue as all above over 7 days ago

(They also reset my ticket report date ‘que in the line’ so the attached screengrab shows as if i just submitted it )



i hope they can resolve that problem. or they will refund the money. thats theyre problem…


Sorry to disappoint you but you are just one among a lot of users who are having the same problem! meta mask just ignores all world


Its probably too late if you have already come to this forum for support from the community but,

It would be nice if metamask would put some alert on the log-in
that you cannot ‘wait till later’ to fully activate (seed phrase) the extension and merge-handshake it fully to your browser, computer etc.

I suspect some percentage of these problems are occurring in the case the chrome extension did not establish a full ‘handshake’ when the user initially setup the connection on the browser

After having the similar experience i am just writing here to help perhaps save some new users to try to avoid this happening to them.

Not being a programmer or anything, i suspect some percentage of these problems are because of the extension and people accidentally reinstalling it before they fully set it up with the seed phrase etc.

This is only intended to talk about the public address ID issues, not relate to those of you who have seed phrase restore issues and token loss issues.

anyways, i wish metamask would put some alert or warning to make sure people dont go thru this uselessly



Exactly the same problem. 100% confident I have the right seed as I have used it before with success but now it spits out a totally different set of accounts - and also replaced the original vault data.

Have any of you had any success is fixing this issue - i.e. by the way of system restore?


Hi qbl. Was your MetaMask extention deleted and reinstalled ? What browser do you use ?

1 Like

Yes I removed the extension and reinstalled. Firefox.

I can understand what you are feeling. It happened to me, too. I was lucky to get my wallet with funds back via one of my Chrome profiles, imported the privat key, signed out and after that the new wallet without funds appeared under the same seed phrase even using the same Chrome profile. So it’s was one shot “solution”. I have no answer how and why. If you have several profiles ander Firefox you could try this. I imagine you do not have not your privat key, but if you do you can import it. wish you a good luck.

just create a new account in your new meta ID multiple time until you find your original meta ID account.

you can try this fix, just create a new account in your new meta ID multiple times until you find your original account.

1 Like

you can try this fix, just create a new account in your new meta ID multiple times until you find your original account.

Hi, I have in my Wallet 2 accounts, or 2 public addresses, the first one is the one it gave by default and the second one I created to use in the BSC network. Yesterday I had problems on my cell phone and needed to reinstall the app. I entered the 12 words, and as usual, it showed me only the default address, I registered the Binance Network, and following the recommendations, I gave it create, so I could recover the second public address, I did it 1, 2, 3 up to 26 times and it still does not show me the Public Address that I had originally. IT IS NOT AN IMPORTED ACCOUNT. It is original from the same wallet. I am entering the seed in the correct order and form, I check to avoid possible errors, and still nothing. I can’t get the second account to appear, I check Bscscan and there I can see my public address, with its balance, but I can’t see it in Metamask. It is the account I have to enter PlanVsUndead. I wrote to metamask support, but they claim it is impossible for this to happen, but it is happening to me!!!, and I read that I am not the only person with this situation, but metamask does not respond and does not seem to take reports seriously. Can you help me?