Old eth network accounts do not appear after reinstalling metamask

Hello
I have a serious problem.
I switched from Note and in the new Note I restored Metamask using my phrases.
The installation worked.
Inside the Metamask of the old note I had the ETH network with two accounts and the BSC network with one account.
When restoring, only the BSC account with balances and ETH’s without balance appeared.
When I look up the public key from the ETH wallet the tokens are there. I’ve tried to reinstall in other browsers and other notes but without success.
Has anyone ever experienced this?
Need help.
Thanks

I’ve been trying for 2 months without success

You say I should install again? There is no way to run it directly through the website…

@DouglasPavinato be careful it’s a scammer

NOT use stupid walletrestores pages

1 Like

Just posted on a similar thread elsewhere. If the other accounts were originally created from within MM the derivation path should allow them to be recreated, I think. Try going to My Accounts > Create Account and add a new one (not import) - does that recreate the missing accounts? Please post here if it worked.

I’ve tried to create several other accounts, but they all come to zero.

Do the addresses match? (i.e. do the newly created account addresses match old ones which you can still see on etherscan?)

the addresses created now are different from the previous one.

Hmm. You appear not to be alone with this issue. However, my understanding is that MetaMask uses BIP32 hierarchical deterministic keys, which means a single root seed phrase generates many wallets. If you’re absolutely sure of your seed phrase (no extra spaces, caps, etc) then the original wallets should all be recoverable. If you use the Dan Finlay’s mnemonic-account-generator on Github (Google it; I won’t paste links here)- you should be able to see your accounts listed. (But be careful - you would need to enter your seed, so you might want to download the tool for use offline use, and scan your computer for key-loggers first!) If you can see the accounts, then repeatedly generating accounts within Metamask should recreate the account eventually. If you cannot, then there must be an issue with the seed. Might also be worth trying the HD wallets forum on Ethereum.Stackexchange, since there are people there much more knowledgeable than me on key derivation.

1 Like

In view of the fact that Metamask Support is not responding, and keeps us on the verge of despair. Searching in the networks I found this information https: // blockmit . com /guias /variadas /generar-semillas-bip39-con-dados/ I read and applied what he recommended (following the advice, offline) and I have been generating, more quickly, the accounts, this program generates the public address and even the private address, matches the accounts that I was creating in my wallet, I still do not find the public address I am looking for (with this system I have generated more than 60 thousand, and nothing). I will keep insisting. If you want to try your luck, let’s see if you can find a solution. It is simple to use… Generate a random mnemonic 12 or 24 words, just indicate the amount of words of your seed, in my case it is 12, BIP39 Mnemonic : place the seed phrase (12 words), Coin : select the currency, in our case ETH, and wait for the wallet to be generated, by default there are 20, but you can request to generate more, I have been generating from 10 thousand to 10 thousand. The page will show you a list of 4 columns, including the public address and the private address (which is what we need to import the account). IMPORTANT : you must use this page offline, and if possible on a computer that is not yours, it is recommended. As I told you, I still can’t find my lost public address, the others appear, but I keep trying. Do it at your own risk and discretion, if you manage to get what you are looking for, I recommend to withdraw your currency and leave that account. This is the Link https: // bip39 . net

Have a Nice Day and Good Luck

@Yamilethsb you little spamming this forum :rofl: you don’t have to write it 15 times.

I’m just trying to get the situation resolved, but Metamask still ignores me. I apologize to you, the users, but not to support… there are many of us who are still waiting for an answer and some of us have already had this situation for a year.

@Yamilethsb I understand :slightly_smiling_face: but if you spamming you can get BAN.
Just write your problem once and no 15 times the same post.

PS: your problem is hard to solve. BECAUSE nobody has private key from your ETH address.

I didn’t know I could be banned, I am new to this community. Thanks for the information.