Pending transaction , stuck

I bridged in starkgate, but the transaction has been pending for 3 days, and even though I canceled it, it is still pending.
and I can’t make another transaction until this problem is solved.
According to the picture I canceled it, but it’s still in pindang mode. And now there is no option to speed up or cancel a pending transaction.
Also, the transaction can be seen in etherscan.
What should I do? I’m tired


Hello @abolfazl195 !
Welcome to MetaMask community !

What is the status of your transaction in the block explorer?
If it is in Pending status, you probably need to send 0 ETH (If the problem is in the Ethereum network) to yourself with manually increased gas.


my transaction in the block explore

Screenshot (138)
How do I manually increase the gas.
I have no choice

note: should only reset your account when it is suggested by a member of the MetaMask Support team or by MetaMask Activity.
How to contact and inform a member of the MetaMask Support team or by MetaMask Activity for resetting my account.

Your transaction is stuck on the blockchain. Resetting account won’t do anything to solve your issue. Please follow this article guide to fix your issue.



The problem is that you have very low gas in your Starkgate transaction (Nonce - 1) :

I see that you reset your account and sent 0 ETH to your account, but you set the gas to Aggressive (you should have used Advanced and set the gas to about 80 GWEI) - but it is set to 0.3025:

To solve the problem enable Nonce customization when sending a transaction:

And send 0 ETH to your address using Advanced gas settings (so that they would be 2 times more than the current ones) while setting Nonce to 1:


I did everything but it still didn’t work and it gives an error

Screenshot (146)

Can you please reach out to MetaMask Support so they can dig deeper into this? Go to > choose Start a Conversation > answer few questions from the bot and you will be connected. If you can’t find the Start a Conversation button, please try the steps in this article:


Hi @KBeeTheCapybara,
He has already contacted the support team and they suggested what we suggested here. However, the issue still exists.


The screenshot indicates you have 4 pending transactions, yet on-chain you have 3. The error message you’re receiving -32000 I believe ends with “transaction underpriced,” which may mean you have two separate issues going on simultaneously: transactions pending on-chain due to low gas, and a locally stuck transaction preventing you from submitting new transactions.

Try this:

  1. Settings > Advanced > clear activity tab data
  2. Submit the replacement transaction in nonce 1 as their support suggested


  1. RESET account (Make sure you know your seed phrase!!!)

  2. Enable Customize transaction nonce in settings:

  1. Send 0 ETH to yourself (don’t forget to manually write 0) with these settings:


Gas setting:

Market > Advanced


I did everything you said but the problem still persists.

Finally, I found the solution with @Maryam1 help :star_struck:
Thank you, @Maryam1
After doing this, we will do the next step, which is to send 0 Eth …


I am glad that the issue got resolved, and thanks for letting us know.


hello maryam i have multiple stuck transactions and panicing lol

been in this space for a long time but haven’t dealt with this.
it’s more to do with an approval, I’ve sent the earliest transaction affiliation [approving an nft collection to sell] but stuck 3x.

I have set the same nonce number, did 700 gwei or multiple times im not sure with higher gas limit than usual but it’s simply not working] i don’t know what to do. gas limit is also higher. please help.


Hello @Snare, welcome to the MetaMask community,

I have checked your account on the Etherscan and seems like you do not have any pending transactions on the Ethereum network. Under your MetaMask settings, Clear the activity and nonce data and that should help.
Settings> Advanced> Clear activity and nonce data

Please let us know in case you need further assistance.

PS: Seems like you have resolved the issue. If that is the case, please ignore the suggestion.