Restored Account and Mysterious Account 2 Appeared

Hi Everyone, I have tried restoring Metamask on Chrome as I have been using Brave but it doesn’t always work as well as I wanted to. After restoring on chrome extension, now there’s account 2 with no history at all! I haven’t created that account and it’s neither present in phone app and brave browser! is this hack? I have seen similar thing on reddit from a year ago and it’s archived - only says email support!

Each MetaMask wallet is device specific meaning that your password, transaction history, and wallet settings are unique to each device (and instance) to which you have imported your wallet. Any settings, custom tokens, RPC networks, imported private keys, etc that were previously associated with your wallet, will need to be added upon restoring your wallet.

Additionally, when a wallet is restored, a new account/address is automatically generated and your transaction history will not repopulate.

I hope this helps! Let me know if you have any further questions.

Hi, I have figured that out - but It’s very odd to find account number appearing out of nowhere! Sadly you haven’t said why that’s the case. I have deleted and restored again and it’s now disappeared! I don’t know if this is just bug or I’m being hacked! I’m kind terrified with Metamask given I have already being scammed and closed one account!

As I mentioned in my last reply, when a wallet is restored, a new account/address is automatically generated and your transaction history will not repopulate. No cause for alarm :slightly_smiling_face:

That’s not what I’m asking at all. You missing the whole point! I only have one account after restoring, there’s my account - account 1 and mysterious account 2 as well! I hope it’s nothing to worry about and just a bug as I have transfered some eth now.

I have the same problem and when I reinstalled Metamask my all tokens disappeared and new adress nothing more.
Plz tell me brother how to get back my tokens.
I connected bsc and pancake but nothing was changed.
I couldn’t login to my MetaMask wallet even I remember my password to login but their was written that I should reinstall MetaMask.
I didn’t use and google just reinstalled through iPhone App Store and it is impossible to hack in iPhone.
I’m sure that this is because of MetaMask that I lost my tokens.

Hi, have you tried adding the tokens again? cuz after re-installing you still have to add tokens and network again for ur coins to show up! It’s weird that u get 2nd account tho. I reached out to them multiple times they just don’t like a seeing that questions! I was even asked to submit lots more details and they still try not to understand the question.

did u find a solution??

Nope, I just created new one as I had no confidence in that one. All I know it could be compromised. Mimize your risk in crypto as once you loose your funds, best you get is sorry. It’s wild wild west out here.

can you reach me on IG? princessbutbadone

Same problem here. :fearful:

For security reasons I set up a new Portable Firefox Browser just for MetaMask.
After adding the MetaMask extension I restored my account using my seed phrase.
My account was restored - but I am now having a second account called “Account 2”


I did not create this account. How did it get there?

Browser: Firefox 91.0
MetaMask Version: 10.0.1

Its very good question, but am sure metamask is well aware of it as they doing their best to avoid answering this.

Tôi cố gắng đăng nhập metamask nhưng khong dược mặc dù nó đúng mật khẩu sau đó tôi phải xoá tải lại và khi tải lại đăng nhập vào thì xuất hiện tài khoản thứ hai tất cả đồng tiền trong ví lúc trước của tôi đều biến mất ai có thể giải thích giúp tôi điều này không

1 Like