Same Browser, same secret recovery phrase, different accounts, cannot access

EDIT: I’ve been able to solve it but I don’t understand why, please take the time to read both posts. I’d be really thankfull if anyone can explain me why that happend. Thank you

Hello, I really hope someone can help me because I cannot access to my accounts anymore.

I don’t know how but with my secret recovery phrase I can access two accounts both with different addresses, but one with tokens, and one empty. To both I gave the same password to access, and it seems like now Metamask cannot understand which is which.

Once disconnected Metamask from the second address with tokens (the first address was empty), I accessed again Metamask with my password but it opened the address with no tokens!
Disconnected, tried again, it always opened the first address.
Then disconnected again, tried to use the secret recovery phrase and now I cannot access any address, Metamask is stuck at recovering the seed phrase.

Please, someone help me, I’m really starting to freak out.

I tried the Vault Decryptor method, and in my Appdata /Brave/Metamask folder I had multiple *.ldb files each one having different Vaults, and each of them gave me back the same secret recovery phrase, but some showed different accounts linked to it.

Please, someone help me please!
Thank you

There’s is something really weird here.
As a last chance, I’ve been able to connect to the old empty account and tried to add a new account by inserting the same name of the account with tokens that I couldn’t access…

Once added, I found again my tokens!!! How is that possible?

Why my secret recovery phrase can recover only one account but then if I just add a new account with the same name I can retrieve also that one?

Shouldn’t metamask restore all accounts with that secret recovery phrase?

Hi! I’m in the same situation. I have tried to do what you suggested, but it didn’t work! Had you be able to get any answers to this issue ? Any suggestions/help will be really apreciated ! Thanks!

Unfortunately not. The only way to get my account with tokens back was to access the empty wallet account (Account 1) and then add a new account with the same name of the account with tokens I couldn’t access.

That’s still very weird and I hope someone from the DEV team can explain this.
Wish you the best luck

Thank you for answering. I have tried your suggestion, even support team suggested the same, but it didn’t work in my case. Here is the link from the support : My Secret Recovery Phrase restored the wrong account – MetaMask (