Tried to mint avax ape nft, but the transaction failed!?

Dear community, I just tried to mint an axax ape on avaxapes. Everything looked good at first. On initiation of the transaction metamask told me the following: there is no suggested gas fee.

I started the transaction and the mint button appeared on the website, I pushed the button and … nothing happened … grey screen.

I tried to reload the website after some time, but then it looked like before and i could start to mint again.

I tried to accelerate the transaction by giving it some more avax, but it didn`t help and suddenly all apes were minted and my transaction failed.

I now have two explanations for the fail:

  1. Do I first have to adjust the gas fees myself and because I didn`t there were to low to finish the transaction.

  2. I use firefox browser and adjusted it to strict website security. Maybe the website got stuck because of this setting?

Please could someone help me, I´m very sad for not minting an nft and don`t want to have this happen again.