Unable to connect MetaMask wallet to Ledger

This issue is still not resolved? Have tried with Firefox and Chrome, all latest updated versions. Mac/Metamask/Ledger. Basically completely hamstrung until this gets resolved. What alternatives are there to Metamask that can let me interact with DeFi through my Ledger?

Same here, the bridge only works with TRON, ETH no. I’ve tried using ledgerx with firefox, edge, brave. It worked once with Edge after I cleaned browser files, then system files/cache, rebooted the system, opened ledgerx and metamask.

I have the same issue here. It’s basically locking me out of my ledger, quite a big problem.

I disabled all of my extensions (except Metamask) and viola! It works! Chrome 91.0.4472.101 on Mac OS 11.4 Big Sur. Latest version of Ethereum app 1.7.8 on Ledger and latest version of Ledger Live 2.29.0.

1 Like

What extensions did you have installed? If we have any in common that might be the culprit.

I’d suggest you disable everything and go
from there.

I got it to work by Allowing the “Contract Data” in the Etherium App on the Ledger.

As far as I understand if Contract Data is turned to “Not Allowed” you can only transfer ETH. If you “Allow” contract data, it also works for other ERC20 tokens.

So set the contract data to allowed. Open the Etherium app on your ledger → settings → contract data → press the buttons → set it to Allowed.

My metamask bridge integration started working.

1 Like

Yup, I am on Mac. it worked for me. See my post above.

I am able to add Ledger to my MM and it also opens the Ledge Live App when trying to send a confirmation. However, I am prompted with “Open app Ethereum” and as soon as I open the Eth App on my Device, Ledger Live asks me to connect my Ledger again and it starts over again.
Is that a MetaMask issue or Ledger Live issue? Can get the Bridge running…

Solved. For some reason the smart contract data was set to NOT allowed again.

Encountering this problem for the first time, contract data is on, all updates etc., just don’t like seeing that third-party warning message pop up when bridging metamask with ledger live, assuming everyone gets that?

I use Metamask with Brave Browser, and although it is a Chromium fork, it works OK with the Ledger live bridge turned off.
You can import all your things from Chrome to it and has a very similar interphase. Once I tried it, I didn’t look back.

I’ve been successfully using updated Chrome and Brave browsers and the Metamask bridge to Ledger Live ( Chrome 91.0.4472.114 and Metamask 9.6.1). However, I am getting the “Data Present!” warning on my Ledger Nano S when I sign transactions. Should I be concerned? Anyone else getting this warning? And does anyone know exactly what this warning means? I never got this message before this issue and the bridge to Ledger Live fix. Thanks

Okay I was not having this issue until today. After an hour I solve it, not sure exactly how. My setup is MM / Ledger / Brave (last version) / iOS (10.13.6, so not the last version). I tried almost everything on this thread : reinitializing my MM Ledger associated account, removing it from MM, reimporting it. Rebooting Brave and my computer, between those steps. Trying the Ledger Live option, but it was stuck on a loop where I had to install the bridge on the Ledger. I was on the point to abandon, then I think I changed on/off the 3 options on the Ethereum app (Contract, Data, Nounce), disconnect my wallet from Opensea and reconnecting it : I tried a last time and miraculously it worked again…

This is working for me in Firefox v88.0.1 but definitely not working in Chrome Version 91.0.4472.77 (Official Build) (x86_64). Both of the aforementioned are on a MacBook Pro running Big Sur 11.4.

How to slove it pelase help me

Not sure it was the same issue as mine or not.
Few days ago I had issues with my new MiniMac + tried either Chrome or Brave + Ledger Nano X → everything is already in latest version(Ledger FW, Ledger Live, Browser revision) since i just downloaded everything few days ago. Note that i’ve set advance option in MM so ledger live is automatically ON during transaction.
Whenever I try to send any token out from MM(with bsc), it automatically opened Ledger Live then ledger live asked me to turn on my ledger. After i turn my ledger On with ETH app on, it just kept on rejecting from ETH app and asking me to open ETH app in ledger again, repeating like this forever. Transaction never been send out from MM to ledger for me to further approve. Process never been finished.

What i tried and recently works → I use Firefox instead. However, the problem with FF is i cannot enable advance setting in MM to automatically turn on Ledger Live(cannot access the icon). So this option is still not “ON”.
To continue, i manually access Manager option in Ledger Live. Then click on ETH to create account in Ledger live(even i’ve already had it). It will try to proceed to create ETH account until step3, then it just informs ETH account is already there, then stop.
After above description, i just continue to do transaction in MM as usual. However now the connection between MM and Ledger is successful. Ledger asks me to proceed as usual until approving the transaction, not reject me from ETH app in the middle like before.

Cheers

Hi All,

I’ve some approach and would like to make a propose workaround solution. Sometimes it’s not about software version it’s a sequence when we’re opening the application on Ledger

What I found is Ledger Live and device bridge will work every single time when “You already open Ethereum application before start Ledger Live and device bridge”

so instead of let Ledger Live open Ethereum application (on ledger) for us, we must open it by ourself then starting transaction and everything will work perfectly

Please try this approach, I believe it will help

Hi, metamask with ledger works on chromium browser. My OS is mx linux

Ok so it was working fine for me for days, even months, and since today I can’t do anything with my Ledger account linked to MM. Don’t get the confirmation on the ledger. I tried everything : reseting account, rebooting Brave, rebooting iOS, and it’s still not working. I don’t know what I can possibly do, this is frustrating. Why can’t I even have a bug report? I have nothing to share about that issue
Info: I’m using MM Ledger on Brave, iOS. No Ledger Live, Ethereum app opened before as always.

1 Like