Can't connect Ledger to Metamask - Internal JSON-RPC error

Ledger does not connect to Firefox on MacOS.

Firefox v89.0
Metamask v9.5.5

I was able to get Firefox, MM, and Ledger to work as well. However, it does not appear that MM version 9.5.5 supports Polygon network. Has anyone been successfully in adding the Polygon network manually?

I was able to use L2 just fine with both MATIC and Optimism with Firefox!

I can confirm FireFox with MetaMask version 9.5.5 supports Polygon network. I used it on Quickswap just an hour ago.

1 Like

Yes! It works now! MetaMask has that advanced option to use with Ledger Live. That setup works great. Using latest version of Chrome too.

Thank you all, to check the status update for this issue, please refer to this Ledger Connection Issues

Still having an issue connecting the Ledger Nano S to Metamask

Versions
Ledger firmware 2.0.0

Metamask version 9.5.5 or 9.5.7
Firefox: 89.0
Chrome: 91.0.4472.77

All are still giving the “JSON-RPC” error. Firefox took me past the initial error to “Insert your security key to the USB port” >> device already connected and pin entered (tried without pin entered too)

When I click through to an application or settings it shows me two errors
“Couldn’t complete sign-in. try again and be sure to do the follow up action”
And then “Unknown Device State (Code: 1, 9, 0x8007000d)” indefinitely

Cancelling shows the JSON error

Tried rebooting, re-installing, has anyone had any luck or any useful tricks for solving this?

Please refer to the above link and update to v9.5.8

Hi guys,

I experienced this exact issue with my Ledger Nano S yesterday. Very frustrating to have to deal with… Especially if you are a yield farmer and need reliability having to sign multiple transactions per day… Pull your heads in Metamask!!!

Last Night, I Updated to newest available software on all programs/devices:

-Chrome extension update
-Ledger Device update
-Ledger Live Manager update
-Even allowed Ledger Live on Metamask which was kind of the newest/latest possible outcome… This also didn’t work for me last night… I went to bed frustrated and disenchanted !

This morning I tried again and still experienced the problem so I tried one last thing…

-Updated my IOS.

This worked. The connection between Metamask and Ledger Live can be a bit buggy still but luckily my last 5 transactions have worked.

Hope this helps someone because I got very close to losing my crypto last night…
I deleted MM extension from Chrome, being tired and not thinking…
I then in a panicked state had to search around trying to find out if I had saved my private seeds for my multiple accounts… Luckily I had, but HUGE learning lesson for me…
Do me a favour and go save those keys now and store them somewhere safe. Very scary incident…

How do I update my MM? The FAQ says that it updates automatically. But this did not happen for me.

I’ve found @Ricchi and others, I’ve found a potential solution.

I was having an issue issue where I had the ETH app open on the device, as Metamask says to do, prior to “Connecting a Hardware Wallet”

When I had the app open, and clicked, it kept going through to the JSON error.

Try backing out of the app on the device WHILE the connection is loading, this worked for me! Using Firefox for this, MetaMask 9.5.5

I’m having issues with the “auto-update” as well across all browsers @2i2l

MetaMask finally updated to: 9.5.9 on brave Browser.

But the Problem isnt fixed…

Still got the same error, while trying to interact with a smart contract.

I used Firefox now and it worked. So it seems like a problem with Brave/Chrome?
Hopefully they will fix it soon.

I have exactly the same problem, I did the same as you and I don’t know what to do anymore

Yep, it works that way !

You need to activate the Ledger Live option in the advanced option of Metamask

The Ledger Live solution does not help me in any way - a request for transaction confirmation does not come to the hardware wallet. I do not know what to do, I have one such problem? (MAC/CHROME/METAMASK/LEDGER NANO X)

@PrekrasnoGaming Welcome to the MetaMask community.
Is your Ledger Live app currently open and connected to MetaMask?
There’s a Ledger Live toggle in the “Advance” setting that should be turned on as well.

(post deleted by author)

(post deleted by author)