Trying to Transfer USDT from BSC Mainnet to external wallet


It’s pending. Not sure if what I’m doing is legit. I changed Safemoon to USDT (within BSC Mainnet). Now I want to send to a USDT external wallet. Knowing that USDT is an ERC20 token, can I do this? Has it been pending for almost 3 hours because it’s not possible?

BTW, I have some BNB in there for transaction. I tried to transfer ETH from Ethereum Mainnet to BSC Mainnet but that didn’t work. Do I need ETH in BSC Mainnet to transfer to external wallet?

Thanks very much for any assistance


From where to where are you trying to transfer? Is your external wallet Metamask?

USDT although it’s ERC20, they also have wrapped versions in other Networks, so you should be ok. If you received USDT on BSC network, you will have Binance pegged USDT, so you are ok.

Can you send the transaction hash to see what’s going on?

Thx for your response. Here’s the transaction ID - 0xf81704084a29633522c23acedb7d7f98a5d2f66beafc85335f70d94ea6128353
doesn’t show up on bscscan or etherscan

Nonce 7

Amount -0 USDT

Gas Limit (Units) 21000

Gas Price (GWEI) 11.755

Total 0.000247BNB


Transaction created with a value of 0 BNB at 19:27 on 7/29/2021.

Transaction submitted with gas fee of 207230 GWEI at 19:28 on 7/29/2021.

Transaction cancel attempted with gas fee of 115500 GWEI at 22:04 on 7/29/2021

Transaction cancel attempted with gas fee of 148113.45 GWEI at 22:09 on 7/29/2021

Transaction cancel attempted with gas fee of 246855 GWEI at 22:14 on 7/29/2021

Speed up this cancellation


I also see that I’ve done something so that there is some kind of swap happening with my BNB amount… It’s in Queue.

Swap Exact Tokens For Tokens Supporting Fee On Transfer Tokens


Speed Up


From: 0x0305bCFbe203Fdaf336584400eFc3ed98B5B018f

To: 0x10ED43C718714eb63d5aA57B78B54704E256024E


Nonce 6

Amount -0 BNB

Gas Limit (Units) 1406246

Gas Price (GWEI) 5

Total 0.007031BNB

and I just realized i didn’t answer your initial question. I"m transferring from metamask to an exchange (which only accepts USDT as ERC20.

I’d like to cancel if possible…

Yeah, if you need to deposit in ERC20, and you are transferring from BSC network, you are going to lose your USDT. Because they will mever show up on the Exchange.

You have no option to cancel the transaction on Metamask?

By the speed up button shoudl be a cancel one.

I keep trying to cancel - and increasing the fee but it’s not cancelling. I’m also confused as there is no ETH in BSC Mainnet - so from what i sent you are the fees in ETH or BNB? Thx!

and in the transaction detail it says: 0 USDT…
does that mean i didn’t send the amount of $851?

You are in BSC network so the gas fees are paid in BNB.

Let’s hope the transaction fails or cancels so you can do it the right way.

You need to bridge the USDT from BSC network to Ethereum and the transfer from Ethereum network to the ERC20 deposit address of the Exchange.

I know BSC network has been having issues these days and a lot of transactions have been failing or taking forever. So might just need to wait.

Check your wallet address on BSCScan to look at the transaction there, it should show up as pending.

It is giving me the chance to speed up cancellation but when i click on it, the gas fees show up as ETH…

receiving address doesn’t show up on BSCscan either

ok, I am a little confused. Exactly what did you do. You swapped Safemoon for USDT on what exchange? Pancakeswap? then what did you do?

Yes I changed from SAFEMOON to USDT. Then tried to transfer to an exchange…

you have USDT on your Metamask wallet on BSC network, correct, and then you tried to transfer to the exchange deposit address using the send button on Metamask?

Yes. And I’ve realized that may be an issue because the receiving address says it only accepts ERC20 USDT coins. That may be the issue. Either way, I’d like to cancel and as you see I’ve increased gas fees to make that happen but still pending. Should I go higher with gas fees?

meanwhile there is the above I also sent you in which i see within my BNB balance - which is tiny - it says…

Swap Exact Tokens For Tokens Supporting Fee On Transfer Tokens

… and that’s pending. I have no idea what’s happening here and if this is effecting things…

This pending transaction offers to SPEED UP, but then when you click on it, it all shows up as ETH gas fees…

ok, I just checked your wallet, and you have Binance Pegged USD, not USDT. So first thing wrong, your tokens are not USDT.

There doesn’t seem to be any pending transactions, so it is probably an issue on Metamask side. Go to the Settings, Advanced, and the push the reset account button which will clear the history and should clear that pending transaction.

Let’s start with that, and see if we can clear that first.